Deploying LANSA Applications on IBM i

Deploying LANSA Applications on IBM i

You've developed your IBM i application and now you are ready to deploy it. There are a number of ways that you can do this and it will depend on the extent of the deployment. Please refer to:

  • What Types of Applications?
  • What Type of Deployment?

Depending on the type of deployment, you may refer to:

  • How to create a Silent Install

Please note that you must use a DVD or image catalogue to deploy your LANSA IBM i application.

Edition Date November 16, 2011

© LANSA


What Types of Applications?

The types of applications that you may deploy could include:

  • IBM i applications (5250)
  • IBM i web applications
  • The IBM i server components of a client/server application.

What Type of Deployment?

Ý Deploying LANSA Applications on IBM i


What Type of Deployment?

1. If your applications are for a single or limited use, typically deployed within your own organisation, then this guide doesn't apply to you. For this type of deployment you would:

  • Install LANSA on each IBM i server (if necessary), using a standard LANSA installation as described in the Installing LANSA on iSeries Guide.
  • Deploy your application using the standard export / import.

2. If you are deploying commercial packaged applications to remote locations or even deploying an application within a large organisation, you would:

  • Create a custom install program that installs the LANSA run-time and your specific application components, including, potentially, non-LANSA components. To do this, you would make use of the silent install commands and guidelines in this guide.

To support a Silent Installation, LANSA delivers:

  • A set of commands, The LSI* Commands, to support installation, upgrade and modification of a LANSA system.
  • Examples of how to create QINSTAPP, an install program.
  • Guidelines for creating an installation DVD.

You should also review:
  • Moving LANSA Objects between LANSA Systems and Partitions in the Introduction to LANSA for iSeries Guide
  • LANSA for the Web Installation & Configuration in the LANSA for the Web Introduction Guide
  • How to Export from the IBM i in the Installing LANSA on Windows Guide
  • Exporting and Importing in the LANSA for iSeries User Guide.

Ý Deploying LANSA Applications on IBM i

Deploying LANSA Applications on IBM i
What Types of Applications?
1. How to Create a Silent Install
1.1 Getting Started
1.2 Create an Application Install Program
1.2.1 LODRUN command and the QINSTAPP program
1.2.2 Execute the LSI* Commands
1.2.3 Rules for using the LSI* Commands
1.2.4 Multilingual or Non-Multilingual
1.2.5 User Profiles
1.3 The LSI* Commands
1.3.1 LSISETUP - LANSA Setup
1.3.2 LSIINSTALL - LANSA for iSeries Installation
1.3.3 LSIUPDATE - LANSA for iSeries Update
1.3.4 LSIWEBINS - LANSA for the Web Installation
1.3.5 LSIINTINS - LANSA Integrator Installation
1.3.6 LSIINTUPD - LANSA Integrator Upgrade
1.3.7 LSIWSVINS - LANSA for the Web Web Server Installation
1.3.8 LSIWSVUPD - LANSA for the Web Web Server Upgrade
1.3.9 LSIOSUINS - Open System Utilities Installation
1.3.10 LSIIMPORT - LANSA Import
1.3.11 LSIPARTCRT – Partition Initialization
1.3.12 LSICLEANUP - LANSA Cleanup
1.4 Create an Application Install DVD
1.4.1 Create an Install "Image"
1.4.2 Install your Application
1.4.3 What to include on your installation DVD
1.5 Licensing
Appendix A. Sample DVD Layout for your application
Estimating Execution Requirements


1. How to Create a Silent Install

Following are guidelines on how to create your own installation program to "wrap" your application and any LANSA products used by your application into a single install step.

These guidelines are based on how the LANSA installation DVD are created and provide possible way to deliver your application – this is not necessarily the definitive way.

A subset of LANSA commands, the LSI* commands, has been developed to support the silent installation, upgrade and modification of a LANSA system.

A detailed explanation of the LSI* command set is also provided and may be useful, regardless of how you intend to deliver your application.

Also see

1.1 Getting Started

1.2 Create an Application Install Program

1.3 The LSI* Commands

1.4 Create an Application Install DVD

1.5 Licensing

Ý 1. How to Create a Silent Install


1.1 Getting Started

Delivery of your application can be based on how LANSA is delivered or you can develop your own delivery mechanism.

Currently, to install LANSA on a IBM i, you must load the LANSA installation media into the target IBM i and initiate the installation using the LODRUN command.

The LODRUN command runs the QINSTAPP program supplied by LANSA. You are presented with screens to enter the appropriate install settings. These settings are written to various data areas. When the batch install is submitted, it queries these data areas to perform the appropriate install activities.

Note: If you going to use Independent Auxiliary Pool Groups (IASPs) then this command assumes that you have a working knowledge of IASP.
Refer to the 1.3.1 LSISETUP - LANSA Setup command for details.

If you are following the LANSA approach to delivering your application, the procedure for creating your own installation DVD includes:

1. Write your installation program (Refer to 1.2 Create an Application Install Program).

2. Create a master DVD and include LANSA product information, your application and the installation program (Refer to 1.2 Create an Application Install Program).

Regardless of how you deliver your application, you can use the LSI* commands to create a program to install LANSA and your application. This program may do something along these lines:

1. Install LANSA for iSeries.

2. Install any other LANSA Products required.

3. Install any LANSA EPCs required.

4. Create a partition in your new LANSA installation.

5. Install your application in the new partition.

Similarly, if you just need to update one or more LANSA installations it may be useful to "wrap" the required steps so you can perform all the necessary updates with minimal user intervention. For example:

1. Upgrade LANSA for iSeries.

2. Upgrade any other LANSA Products required.

3. Install LANSA EPCs required.

Ý 1. How to Create a Silent Install


1.2 Create an Application Install Program

The LANSA installation DVD includes the library DCXISVLIB containing the LSI* command set. As a starting point restore this library into your development environment using the command:

RSTLIB SAVLIB(DCXISVLIB) DEV(<your opt device>) OPTFILE('/AS400I/DCXISV')

Sample silent installation programs are included in this library DCXISVLIB in source file DCXSRC.

Following is a silent install version of the online install procedures described in the Installing LANSA on iSeries Guide. Refer to the guide for clarification of any points in this text.

  • 1.2.1 LODRUN command and the QINSTAPP program
  • 1.2.2 Execute the LSI* Commands
  • 1.2.3 Rules for using the LSI* Commands
  • 1.2.4 Multilingual or Non-Multilingual
  • 1.2.5 User Profiles

Ý 1. How to Create a Silent Install


1.2.1 LODRUN command and the QINSTAPP program

To start with let's have a look at how the LODRUN command works.

The IBM supplied Load and Run Media Program (LODRUN) command restores a user-written program object from tape, diskette, or optical device into the library QTEMP. The system passes the device name to the restored program and transfers control to the restored program.

When the LODRUN command is executed:

1. The media is searched for the user-written program, which must be named QINSTAPP and saved from library QTEMP.

2. The QINSTAPP program is restored to the QTEMP library using the RSTOBJ command.

3. Control of the system is passed to the QINSTAPP program. The QINSTAPP program can be used, for example, to restore other applications to the user's system and run those applications.

Note: The program QINSTAPP must be owned by a user profile that resides on the target system. If QINSTAPP is restored to a system that does not have the owning user profile, control is not transferred and the program is not run.

4. When the user logs off, the QINSTAPP program is removed from the system.

The QINSTAPP program is not supplied by LANSA.

When you supply a QINSTAPP program, you are responsible for writing and supporting it. The program can be designed to accomplish many different tasks. For example, the program could:

    Restore and run other programs or applications.

    Restore a library.

    Delete another program or application.

    Create specific environments.

    Apply fixes to existing applications.

The QINSTAPP program is run only once each time the LODRUN command is entered. The LODRUN command has only one mandatory parameter (DEV), which specifies the device from which the QINSTAPP program is restored.

For example: Restore the Program QINSTAPP from a DVD

LODRUN DEV(OPT01)

This command restores the program object QINSTAPP from the DVD on device OPT01 to the library QTEMP. The filename for the QTEMP library on the DVD is APP1/INST/QTEMP. Control is then transferred to the restored program. If the file is not found, an escape message is sent.

To install LANSA and your application, your QINSTAPP program may be structured to look something like this:

PGM PARM(&DEV)

*restotr the command LSISETUP and DC@LCP060

RSTOBJ OBJ(LSISETUP) SAVLIB(DCXISVLIB) +

DEV(&DEVNAME) RSTLIB(QTEMP) +

OPTFILE('/AS400/LOADLIB')

RSTOBJ OBJ(DC@LCP060) SAVLIB(DCXISVLIB) +

DEV(&DEVNAME) RSTLIB(QTEMP) +

OPTFILE('/AS400/LOADLIB')

* Setup environment

LSISETUP DEVICE(&DEVNAME)

* Install LANSA

LSIINSTALL PGMLIB(&PGMLIB) CONNIDN(4695)

…

* Install LANSA Integrator

LSIINTINS …

* Clean-up the work environment

LSICLEANUP

…

* Install your application

LANSA IMPORT(MYAPPINST)

…

ENDPGM

Refer to IBM documentation for more detail on the LODRUN command.

Ý 1.2 Create an Application Install Program


1.2.2 Execute the LSI* Commands

When your install application program (QINSTAPP) is executed on the target system, the actual values used on the LSI* command parameters will be updated in the appropriate data area(s) on the system where the install is executed.

If the LANSA data areas do not already exist they will be created.

You must use the QSECOFR or QOTHPRDOWN profiles during the installation. The use of other profiles, or the removal of the special authorities, will cause security and integrity alterations to the installed system.

Ý 1.2 Create an Application Install Program


1.2.3 Rules for using the LSI* Commands

If your program executes both LANSA product installs and upgrades, each block of install commands must be preceded by LSISETUP and followed by LSICLEANUP. A new LSISETUP should then be issued before executing any upgrade commands.

The LANSA product install commands are:

LSIINSTALL

LSIINTINS

LSIWEBINS

LSIWSVINS

The LANSA product update commands are:

LSIUPDATE

LSIINTUPD

LSIWSVUPD

All remaining LSI* commands must still be preceded by LSISETUP and followed by LSICLEANUP but can be mixed with the install and update commands.

For example, your program may be structured something like this:

For Install

LSISETUP

LSIINSTALL

LSIWEBINS

LSIINTINS

your application

LSICLEANUP

For Upgrade

LSISETUP

LSIUPDATE

your application

LSICLEANUP

You will find some example code in DCXISVLIB/DCXSRC

Ý 1.2 Create an Application Install Program


1.2.4 Multilingual or Non-Multilingual

Ensure the partition where your application is to be installed matches the LANSA application development partition. This includes:

  • Setting the partition as multilingual (or not).
  • Ensuring the partition is enabled for RDMLX (or not).

Any required languages will be automatically created if your LANSA application is installed using LANSA Import.

Ý 1.2 Create an Application Install Program


1.2.5 User Profiles

Ensure any user profiles required to support your LANSA application exist on the target system.

Ý 1.2 Create an Application Install Program


1.3 The LSI* Commands

LANSA supplies a specialized set of commands to support the automated installation and upgrade of LANSA products and the installation of LANSA-written applications.

This allows a CL program to be written to encapsulate the installation and/or upgrade of LANSA products and importing of a LANSA application.

Following is the list of commands that are provided to support the silent installation or upgrade of LANSA and LANSA based applications:

1.3.1 LSISETUP - LANSA Setup | Create work environment – must be run before other commands
1.3.2 LSIINSTALL - LANSA for iSeries Installation | Install LANSA for iSeries
1.3.3 LSIUPDATE - LANSA for iSeries Update | Upgrade LANSA for iSeries
1.3.4 LSIWEBINS - LANSA for the Web Installation | Install LANSA for the Web
1.3.5 LSIINTINS - LANSA Integrator Installation | Install LANSA Integrator
1.3.6 LSIINTUPD - LANSA Integrator Upgrade | Upgrade LANSA Integrator
1.3.7 LSIWSVINS - LANSA for the Web Web Server Installation | Install LANSA for the Web Web Server
1.3.8 LSIWSVUPD - LANSA for the Web Web Server Upgrade | Upgrade LANSA for the Web Web Server
1.3.9 LSIOSUINS - Open System Utilities Installation | Install Open System Utilities
1.3.10 LSIIMPORT - LANSA Import | Import shipped LANSA save file
1.3.11 LSIPARTCRT – Partition Initialization | Partition Initialization
1.3.12 LSICLEANUP - LANSA Cleanup | Clean-up work environment – must run after install or upgrade set

All commands validate the command parameters, send appropriate messages to the program message queue and return a status code indicating the success or otherwise of the requested action. Any messages can be picked up programmatically.

Most of the parameters you would be able to set in a custom installation are available on the new install and upgrade commands.

The install commands will create the appropriate LANSA data areas, as is done in a normal Custom install. Any upgrade commands will refer to and update these LANSA data areas accordingly.

Ý 1. How to Create a Silent Install


1.3.1 LSISETUP - LANSA Setup

The LSISETUP command must be executed at the beginning of your install program before any other LSI* commands.

LSISETUP creates a work library LANSAWRK99 (which is deleted by the LSICLEANUP command) and adds this library to the library list. All the required objects are then restored from the LOADLIB into this library. LSISETUP also sets up environment variables and values which are referenced by the other LSI* commands.

The device name of your optical drive must be supplied for use in other commands.

Note:

If you are using Independent Auxiliary Pool Group (IASP) consider the following:

Because the LSISETUP command can be anywhere in your Install/Upgrade program, it is best to set the ASPGRP parameter to *JOB in LSISETUP command and set the jobs ASP group by using IBM i command SETASPGRP.

You could use any one of the following four scenarios:

  • You can set the job's ASP group by changing the job description's user profile parameter INLASPGRP to a required ASP group name. When this user signs on, the job's ASP group will be set to the ASP group name that was in the job description.

Or

  • After signing on you can use the IBM i SETASPGRP command to set the job to the required ASP group.

Or

  • If you are running your install/upgrade job in batch mode you can specify the ASP group in the SBMJOB command's INLASPGRP parameter to the ASP group that you are going to use.

Or

  • If the job that is submitting your install/upgrade has already set the correct ASP group then use *CURRENT in the SBMJOB commands INLASPGRP parameter.

If you require more information about IASP, refer to Using Independent Auxiliary Storage Pool (IASP) in the Installing LANSA on IBM i Guide.

Required

LSISETUP -------- DEVICE ---------- OPT01 ----------------------->

Device name

>-- ASP -------------- 1 -------------------------->

1-32 or *ASPDEV

>-- ASPDEV ---------- *ASP ------------------------>

*ASP or ASP device name or

*ASPGRP

>-- ASPGRP ---------- *NONE ------------------------|

JOB, NONE or ASP Group name

Keywords

DEVICE | The name of the optical device
ASP | Indicates whether objects are to be restored into a given ASP or IASP device. If using ASP: A value between 1 and 32 is valid The default is 1. If using IASP then this must be *ASPDEV.
ASPDEV | If using ASP then this must be *ASP. If using IASP this must be a valid IASP device name or *ASPGRP. If you use *ASPGRP then the IASP device name and ASP Group name are same. If you are using IASP then the device that is been used must be on-line. The default *ASP.
ASPGRP | If using ASP then the value is *NONE. If using IASP This value must be ASP group name or *JOB. When *JOB is specified the ASP group name is derived from the current job. The default is *NONE.

Ý 1.3 The LSI* Commands


1.3.2 LSIINSTALL - LANSA for iSeries Installation

The LSIINSTALL command installs a standard LANSA for iSeries system including the standard partitions SYS and DEM.

For a typical installation it is recommended that you provide a unique value for the program library (PGMLIB) and optionally the Listener Connection Port (CONNIDN) and Company Name (COMPANY). In most cases, the default values will be sufficient for all other parameters.

LANSA for the Web is not installed as part of the LSIINSTALL command. LANSA for the Web is installed separately using the LSIWEBINS command.

The LANSA for iSeries installation does NOT import any of the shipped import files. Refer to LSIIMPORT for more details.

For information to clarify the actions of these commands, refer to the Installing LANSA on iSeries Guide.

Required

LSIINSTALL ------ PGMLIB ---------- *DFT ------------------------>

library name

>-- DTALIB ---------- *DFT ------------------------>

library name

>-- COMLIB --------- *DFT ------------------------>

library name

>-- COMPANY --------- *DFT ------------------------>

company name

>-- SYSLIB ---------- *DFT ------------------------>

library name

>-- SYSRDMLX -------- NO -------------------------->

YES

>-- DEMLIB ---------- *DFT ----------------------->

library name

>-- DEMRDMLX--------- NO -------------------------->

YES

>-- RIFS ------------ *DFT ------------------------>

directory

>-- DEVLNG ---------- *DFT ------------------------>

ENG

FRA

JPN

>-- SYSOWN ---------- *DFT ------------------------>

user profile

>-- SECOFR ---------- *DFT ------------------------>

user profile

>-- JOBD ----------- *DFT ------------------------>

job description

>-- SBSDNM ---------- *DFT ------------------------>

subsystem

>-- JOBDNM --------- *DFT ------------------------>

job description

>-- JOBQNM ---------- *DFT ------------------------>

job queue

>-- CONNIDN --------- 04545 ----------------------->

port number

>-- IFS ------------- *DFT ------------------------|

directory

Keywords

PGMLIB

The program library nominated is used to identify the LANSA system. The library nominated must not already exist on the system.

The default value, *DFT, is DCXPGMLIB.

The respective library names are derived using the first three characters of the program library as a prefix and a predetermined suffix. For example, if the program library is set to ABCPGMLIB the data library will be derived as ABCDTALIB.
DTALIB

The LANSA system data library. The library nominated must not already exist on the system.

The default value, *DFT, is derived using the first three characters of the program library as a prefix and the suffix DTALIB. For example, ABCDTALIB.
COMLIB

The LANSA system communications library. The library nominated must not already exist on the system.

The default value, *DFT, is derived using the first three characters of the program library as a prefix and the suffix COMLIB. For example, ABCCOMLIB.
COMPANY

A textual value to identify the company/organization installing LANSA.

It is recommended that you center the company/organization in the 30 characters available.
SYSLIB

The partition library for the SYS partition. The library nominated must not already exist on the system.

The default value, *DFT, is derived using the first three characters of the program library as a prefix and the suffix MODLIB. For example, ABCMODLIB.
SYSRDMLX

Indicates whether the SYS partition should be RDMLX enabled. The default value is NO.
DEMLIB

The partition library for the DEM partition. The library nominated must not already exist on the system.

The default value, *DFT, is derived using the first three characters of the program library as a prefix and the suffix DEMOLIB. For example, ABCDEMOLIB.
DEMRDMLX

Indicates whether the DEM partition should be RDMLX enabled. The default value is NO.
RIFS

The LANSA root directory used by all LANSA objects that require the IFS. It is recommended that you use the default path /LANSA_<pgmlib>/.
DEVLNG

The default value, *DFT, is derived from the iSeries system values. Only English (ENG), French (FRA) and Japanese (JPN) are supported as development languages.
SYSOWN

The LANSA installation product owner. The default value, *DFT, is QOTHPRDOWN. This profile will be automatically created if it does not already exist.

Specify an existing OS/400 user profile to be the owner of this LANSA for iSeries system. This user will own any objects subsequently created by the LANSA for iSeries installation.
SECOFR

Specify the name of an existing OS/400 user who is to be the Partition Security Officer for the DEM and SYS partitions.

The default value is a user profile with the same name as the LANSA Program Library, for example DCXPGMLIB. If this default profile does not exist it will automatically be created.

JOBD

The job description used by the LANSA installation. The default value, *DFT, uses the program library prefix with the suffix JOBD. For example, ABCJOBD.
SBSDNM

The Listener subsystem. The default value, *DFT, uses the LANSA program library.
JOBDNM

The Listener job description. The default value, *DFT, uses the program library prefix with the suffix LISTJD. For example, ABCLISTJD.
JOBQNM

The Listener job queue. The default value, *DFT, uses the program library prefix with the suffix LISTJQ. For example, ABCLISTJQ.
CONNIDN

The default connection port for the listener is 4545. Port number must be five characters long.

IFS

The LANSA communications sub-directory. The default value, *DFT, is /connect below the LANSA root directory. For example, /LANSA_dcxpgmlib/connect.

Ý 1.3 The LSI* Commands


1.3.3 LSIUPDATE - LANSA for iSeries Update

The LSIUPDATE command upgrades a standard LANSA for iSeries system.

The system to be upgraded is identified by supplying the program library. All other information is derived from the LANSA system definition data areas.

LANSA for the Web will be automatically upgraded by the LSIUPDATE command if it has been previously installed.

Refer to the Installing LANSA on iSeries Guide for details of the upgrade paths available.

Required

LSIUPDATE --------- PGMLIB ---------- program library ------------|

Keywords

PGMLIB

Enter the program library associated with the LANSA system to be upgraded.

Ý 1.3 The LSI* Commands


1.3.4 LSIWEBINS - LANSA for the Web Installation

The LSIWEBINS command installs LANSA for the Web on an existing LANSA system.

There is no LANSA for the Web upgrade. When performing a LANSA for iSeries upgrade, if LANSA for the Web has been previously installed it will be automatically upgraded by the LSIUPDATE command.

Required

LSIWEBINS ------- PGMLIB ---------- program library ------------->

>-- WEBSRV --------- CGI ------------------------->

JAVASRVLET

>-- SRVTYPE -------- APACHE ---------------------->

>-- INSNAME -------- *PGMLIB --------------------->

library name

>-- WEBPORT -------- 00080 ----------------------->

port number

>-- JOBQMEB -------- *DFT ------------------------>

job queue

>-- JOBQWEB -------- *DFT ------------------------>

job queue

>-- WRKLIB --------- *DFT ------------------------>

library name

>-- IFSIMAGES ------ *DFT ------------------------>

directory

----------------------------------------------------

Optional

>-- CGILIB --------- *COMLIB --------------------->

library name

>-- HOSTCCSID ------ *DFT ------------------------>

CCSID

>-- CLNTCCSID ------ *DFT ------------------------>

CCSID

>-- JVAIFS --------- *DFT ------------------------|

directory

Keywords

PGMLIB | The program library must already exist. The library nominated is used to identify the LANSA for iSeries system to apply the LANSA for the Web install against.
WEBSRV | The default value, CGI, is recommended.
SRVTYPE | Only the default value, APACHE, is supported at this stage.
INSNAME | The HTTP instance name defaults to the program library nominated on the keyword PGMLIB.
WEBPORT | The default instance port is 00080. Port number must be five characters long.
JOBQMEB | The Web Monitor Job Queue. The default value, *DFT, is derived using the first three characters of the program library as a prefix and the suffix WEBJQ. For example, ABCWEBJQ.
JOBQWEB | The Web Jobs Job Queue. The default value, *DFT, is derived using the first three characters of the program library as a prefix and the suffix WEBJQ. For example, ABCWEBJQ.
WRKLIB | The Web Work Library. The default value, *DFT, is derived using the first three characters of the program library as a prefix and the suffix WRKLIB. For example, ABCWRKLIB.
IFSIMAGES | The Web Image Path. The default value, *DFT, is /webserver/images below the LANSA root directory. For example, /LANSA_dcxpgmlib/webserver/images.
CGILIB | The default value, *COMLIB, is obtained from the LANSA for iSeries installation.
HOSTCCSID | The Host CCSID used for data translation. The default value, *DFT, is 00037. CCSID must be five characters long, for example '00037'.
CLNTCCSID | The Client CCSID used for data translation. The default value, *DFT, is 00819. CCSID must be five characters long, for example '00819'.
JVAIFS | The Java Servlet sub-directory on the IFS. The default value, *DFT, is /webserver/servlet below the LANSA root directory. For example, /LANSA_dcxpgmlib/webserver/servlet.

Ý 1.3 The LSI* Commands


1.3.5 LSIINTINS - LANSA Integrator Installation

The LSIINTINS command installs LANSA Integrator. This can be a standalone installation or associated with an existing LANSA for iSeries installation.

Required

LSIINTINS ------- JSMLIB --------- *DFT ------------------------->

library name

>-- JSMPATH ------- *DFT ------------------------->

directory

>-- JSMSBSD ------- *DFT ------------------------->

subsystem

>-- JSMTCP -------- 04560 ------------------------>

port number

>-- JSMTCPA ------- 04561 ------------------------>

port number

>-- JSMPORT ------- 00080 ------------------------->

port number

>-- JSMOPT5 ------- *NO -------------------------->

*YES

----------------------------------------------------

Conditional

>-- PGMLIB -------- program library -------------->

>-- SYSOWNJ ------- *DFT ------------------------->

user profile

>-- JSMUSRJ ------- *DFT -------------------------|

user profile

Keywords

JSMLIB

The default value, *DFT, is derived using the first three characters of the program library as a prefix and the suffix JSMLIB. If a program library is not supplied the default value is DCXJSMLIB. The library nominated must not already exist on the system.
JSMPATH

The Java Service Manager Path.

The default value, *DFT, is /jsm/instance below the LANSA root directory (if associated with a LANSA for iSeries installation by supplying the program library) or the automatically generated Integrator Root Directory if this is an independent installation. For example, if a program library is supplied the path may be /LANSA_dcxpgmlib/jsm/instance and if no program library is supplied the path may be /LANSA_dcxjsmlib/jsm/instance.
JSMSBSD

The Integrator Subsystem name.

The default value, *DFT, is the Java Service Manager library. For example, ABCJSMLIB
JSMTCP

Integrator TCP port.

The default value, *DFT, is 04560. Port number must be five characters long.
JSMTCPA

Integrator TCP Administration port.

The default value is 04561. Port number must be five characters long.
JSMPORT

HTTP server Port number.

The default value is 00080. Port number must be five characters long.
JSMOPT5

Optimize the Java Service Manager.

The default value, *NO indicates that the JSMOPT command should not be submitted.
PGMLIB

Conditional. If LANSA Integrator is associated with a LANSA system enter the program library for this system.

If a program library is provided the respective library names are derived using the first three characters of the program library as a prefix and a predetermined suffix. For example, if the program library is set to ABCPGMLIB the jsm library will be derived as ABCJSMLIB.

If a program library is provided the keywords INJASP, SYSOWNJ and JSMUSRJ should not be supplied as the values will be picked up from the LANSA system associated with the program library.
SYSOWNJ

Conditional. The Integrator owner user profile.

The default value, *DFT, is QOTHPRDOWN.

Do not enter if a program library is provided.
JSMUSRJ

Conditional. Integrator user Id

The default value, *DFT, DCXJSMLIB.

Do not enter if a program library is provided.

Ý 1.3 The LSI* Commands


1.3.6 LSIINTUPD - LANSA Integrator Upgrade

LSIINTUPD command upgrades an existing LANSA Integrator installation. This can be a standalone installation or associated with an existing LANSA for iSeries installation.

Required

LSIINTUPD ------- JSMLIB ---------- library name --------------|

Keywords

JSMLIB

Enter the JSM library to identify the JSM installation to be upgraded.

Ý 1.3 The LSI* Commands


1.3.7 LSIWSVINS - LANSA for the Web Web Server Installation

The LSIWSVINS command installs a LANSA for the Web Web Server.

Required

LSIWSVINS -------- ADMLIB -------- *DFT ------------------------->

library name

>-- COMLIB -------- *DFT ------------------------->

library name

>-- WRKLIB -------- *DFT ------------------------->

library name

>-- SYSOWN -------- *DFT ------------------------->

user profile

>-- INSNAME ------- *ADMLIB ---------------------->

instance name

>-- WEBPORT ------- *DFT ------------------------->

port number

>-- WEBSRV -------- CGI -------------------------->

JAVASRVLET

>-- SRVTYPE ------- APACHE ----------------------->

>-- DEVLNG -------- *DFT ------------------------->

ENG

FRA

JPN

>-- RIFS ---------- *DFT ------------------------->

directory

>-- IFSIMAGES ----- *DFT ------------------------->

directory

----------------------------------------------------

Optional

>-- CGILIB -------- *COMLIB ---------------------->

library name

>-- HOSTCCSID ----- *DFT ------------------------->

CCSID

>-- CLNTCCSID ----- *DFT ------------------------->

CCSID

>-- COMDIR -------- *DFT ------------------------->

directory

>-- JVAIFS -------- *DFT -------------------------|

directory

Keywords

ADMLIB

The default value, *DFT, will set the administration library as DCXADMLIB. The library nominated must not already exist on the system.

If a specific value is not provided for other library keywords, the respective library names are derived using the first three characters of the administration library as a prefix and a predetermined suffix. For example, if the administration library is set to ABCADMLIB the communications library will be derived as ABCCOMLIB.

Warning – If installing a single-tier model (i.e. web server and data/application server on a single iSeries) do not use the same prefix for the web server Administration library and the data/application program library.
COMLIB

The LANSA system communications library. The library nominated must not already exist on the system.

The default value, *DFT, is derived using the first three characters of the administration library as a prefix and the suffix COMLIB. For example, ABCCOMLIB.
WRKLIB

The Web Work Library.

The default value, *DFT, is derived using the first three characters of the administration library as a prefix and the suffix WRKLIB. For example, ABCWRKLIB.
SYSOWN

The LANSA web server product owner. The default value, *DFT, is QOTHPRDOWN. This profile will be automatically created if it does not already exist.

Specify an existing IBM i user profile to be the owner of this Web Server installation. This user will own any objects subsequently created by the installation.
INSNAME

The HTTP instance name defaults to the administration library nominated on the keyword ADMLIB.
WEBPORT

The default instance port is 80. Port number must be five characters long, for example '00080'.
WEBSRV

The default value, CGI, is recommended.
SRVTYPE

Only the default value, APACHE, is supported at this stage.
DEVLNG

The default value, *DFT, is derived from the iSeries system values. Only English (ENG), French (FRA) and Japanese (JPN) are supported as development languages.
RIFS

The LANSA root directory used by all LANSA objects that require the IFS. It is recommended that you use the default path /LANSA_<admlib>/.
IFSIMAGES

The Web Image Path.

The default value, *DFT, is /webserver/images below the LANSA root directory. For example, /LANSA_dcxadmlib/webserver/images.
CGILIB

The default value, *COMLIB, is obtained from the Communications Library keyword.
HOSTCCSID

The Host CCSID used for data translation.

The default value, *DFT, is 00037. CCSID must be five characters long, for example '00037'.
CLNTCCSID

The Client CCSID used for data translation.

The default value, *DFT, is 00819. CCSID must be five characters long, for example '00819'.
COMDIR

The communications sub-directory on the IFS.

The default value, *DFT, is /connect below the LANSA root directory. For example, /LANSA_dcxadmlib/connect.
JVAIFS

The Java Servlet sub-directory on the IFS.

The default value, *DFT, is /webserver/servlet below the LANSA root directory. For example, /LANSA_dcxadmlib/webserver/servlet.

Ý 1.3 The LSI* Commands


1.3.8 LSIWSVUPD - LANSA for the Web Web Server Upgrade

The LSIWSVUPD command upgrades an existing LANSA for the Web Web Server.

Required

LSIWSVUPD ------ ADMLIB -------- library name ----------------|

Keywords

ADMLIB

Enter the Administration library to identify the Web Server to be upgraded.

Ý 1.3 The LSI* Commands


1.3.9 LSIOSUINS - Open System Utilities Installation

The LSIOSUINS command installs the LANSA Open System Utilities into the nominated library.

Required

LSIOSUINS ------- OSULIB ---------- *DFT ------------------------|

library name

Keywords

OSULIB

Enter the library where the Open System Utilities are to be installed.

The default value, *DFT, is DCXOSULIB.

Ý 1.3 The LSI* Commands


1.3.10 LSIIMPORT - LANSA Import

The LSIIMPORT command imports a LANSA installation save file into the LANSA system and partition nominated. The imports must be included on the installation DVD under the directory /as400i.

Only import files provided on the LANSA installation DVD can be imported using this command. Any other imports required should using the standard LANSA IMPORT command.

Note: The LANSA for iSeries installation (LSIINSTALL) does NOT import any save files. Any imports supplied by LANSA that you require to be applied to your LANSA installation must be individually imported using the LSIIMPORT command.

To web enable a partition import the save file LWEBSF into the partition to be enabled.

System variables and templates are system level objects so the related imports can be applied to any partition.

Required

LSIIMPORT -------- PGMLIB ---------- library name ---------------->

>--- PARTITION ------- partition id ---------------->

>--- IMPFILE -------- save file -------------------|

Keywords

PGMLIB | Enter the program library associated with the LANSA system to import into.
PARTITION | The partition to import into.
IMPFILE | The name of the save file to import from the installation DVD.

Ý 1.3 The LSI* Commands


1.3.11 LSIPARTCRT – Partition Initialization

The LSIPARTCRT command creates a partition on an existing LANSA system. The new partition definition is based on an existing partition in the nominated LANSA system.

Required

LSIPARTCRT ------- PGMLIB ---------- library name ---------------->

>--- PARTITION ------- partition id ---------------->

>--- TEXT ----------- description ----------------->

>--- MODLIB ---------- *DFT ------------------------>

library name

>--- DFTFILELIB ------ *MODLIB --------------------->

library name

>--- FRMPART --------- DEM ------------------------->

partition id

>--- RDMLX ----------- NO --------------------------|

YES

Keywords

PGMLIB

Enter the program library associated with the LANSA system where the new partition is to be created.
PARTITION

A three letter partition identifier. For example, PRD.
TEXT

A description for the new partition.
MODLIB

The module library for the new partition. The library nominated must not already exist on the system.

The default value, *DFT, is derived using the partition identifier as a prefix and the suffix MODLIB. For example, PRDMODLIB.
DFTFILELIB

The data library for the new partition.

The default value, *MODLIB, uses the module library parameter.
FRMPART

Nominate an existing partition to use as the basis for the new partition. If this is a new installation only DEM and SYS partitions will already exist. The default value is DEM.

DEM – Multilingual

SYS – Not multilingual
RDMLX

Indicate if the partition should be enabled for RDMLX. The default value is NO.

Ý 1.3 The LSI* Commands


1.3.12 LSICLEANUP - LANSA Cleanup

The LSICLEANUP command deletes the work library LANSAWRK99 and must be executed after all your LSI* commands have been executed.

Required

LSICLEANUP ------- USELIB ---------- *YES ---------------------->

*NO

>--- ENVVAL --------- *YES ----------------------|

*NO

Keywords

USELIB | Remove the work library. The default value, *YES, is recommended.
ENVVAL | Remove the environment variables. The default value is, *YES, is recommended.

Ý 1.3 The LSI* Commands


1.4 Create an Application Install DVD

  • 1.4.1 Create an Install "Image"
  • 1.4.2 Install your Application
  • 1.4.3 What to include on your installation DVD

Ý 1. How to Create a Silent Install


1.4.1 Create an Install "Image"

In addition to writing the QINSTAPP program, you need to create a DVD containing the program and any supporting objects. To distribute the program on an optical device, do the following:

1. Prepare the DVD (INZOPT).

2. Use the Create Duplicate Object (CRTDUPOBJ) command to create the QINSTAPP program into the QTEMP library.

3. Use the Save Object (SAVOBJ) command to save the QINSTAPP program from QTEMP to the optical device.

Use the Save Object (SAVOBJ), Save Library (SAVLIB), or Save License Program (SAVLICPGM) command to save any other necessary applications, programs or libraries to the DVD.

Ý 1.4 Create an Application Install DVD


1.4.2 Install your Application

How you package and install your application is your responsibility.

Typically, your application may be exported to a save file using LANSA EXPORT. This save file can then be imported as part of your install program using the LANSA IMPORT command.

Ý 1.4 Create an Application Install DVD


1.4.3 What to include on your installation DVD

Some of the libraries and objects supplied on the LANSA installation DVD must be included on your own application installation DVD.

What you must include

  • The /as400 directory must exist on your installation DVD to use the LSI* command set.
  • If you intend to use the LSIIMPORT or LSIPARTCRT (to create an RDMLX enabled partition) commands your installation DVD you must include the /as400i directory and any appropriate sub-directories.
  • The /epci/epcload directory must exist on your Installation DVD.
  • Always include the legal.htm document from the LANSA install DVD.
  • Refer to Appendix A. Sample DVD Layout for your application for more information.

Other things you may want to include

  • LANSA documentation or a link to the LANSA documentation at http://www.lansa.com.au/support/docs/index.htm

Considerations when creating your installation DVD

  • Do you need multilingual support? What languages?

Only include the French and Japanese objects from the LANSA installation DVD if these languages are supported by your application. (Removing them will significantly reduce the size of the install image.)

  • What LANSA products do you need to install?
  • Do you have licenses for LANSA Products to distribute with the DVD?
  • What LANSA imports do you need to support your application?

Applying EPCs

1. Ship the EPC a save file in the load library.

2. Add the following code:

LOADEPC EPCNUM(&EPCNUM) USE(*LIB) +

SAVF(&USELIB/DCXEC834) PGMLIB(&PGMLIB)

MONMSG MSGID(CPF0000)

RCLRSC

MONMSG CPF0000

where:

&EPCNUM is the EPC number

&USELIB = where the EPC save file is

&PGMLIB = LANSA program library.

Note:
  • If applying more than one EPC, repeat the command again.
  • This command is shipped in the LANSA program library.
  • The load library is where all install/upgrade programs are. Replace the load library with any library where you can put the EPC save file.
  • You must change save file name to reflect the correct EPC save file. In the example is says DCXEC834.

Ý 1.4 Create an Application Install DVD


1.5 Licensing

Ensure you include appropriate license information for LANSA when you install your application.

LANSA for iSeries

LANSA for iSeries does not require a runtime license. You must have a license for the IBM i on which you do your development, but you do not need a license for the machine on which your application is executed.

LANSA for the Web

To run LANSA for the Web applications you require an appropriate LANSA for the Web Production license.

LANSA Integrator

To use LANSA Integrator you must have a valid key license installed.

LANSA Open System Utilities

You do not require a LANSA license to use the Open System Utilities.

How to Request a LANSA License

To request a LANSA license you need to supply the CPU number, model number and processor feature code of each IBM i where your application (and hence LANSA) is to be installed.

These notes are from LANSA iSeries License in the Installing LANSA on iSeries Guide:

1. Identify your IBM i Processor, Serial and Model Number

2. Sign on to the IBM i.

3. From an i5/OS Command Entry, display your IBM i System Values by entering the following command:

WRKSYSVAL

4. On the Work System Values screen, use option 5 to display the required information.

  • QSRLNBR System serial number
  • QMODEL System model number
  • QPRCFEAT Processor Feature

5. To display a single system value, you may also use the DSPSYSVAL command. For example, DSPSYSVAL QSRLNBR.

You will also find licensing details at http://www.lansa.com.au/support/licensing/index.htm.

Ý 1. How to Create a Silent Install


Appendix A. Sample DVD Layout for your application

Required directories (see lines in red below) from the LANSA Installation DVD must be included on your application medium to support the installation or upgrade of LANSA.

Following is a sample layout. This sample layout excludes all French and Japanese objects. For the exact LANSA install layout, check the directory layout /as400 and /as400i on the installation DVD.

DVD

/Qtemp (LOADRUN – Your LODRUN)

/your_dir |
 | /your_application_lib
/as400 |
 | /comlib
 | /demolib
 | /dtalib
 | /jsm (Optional – Required for LANSA Integrator)
 | /loadlib
 | /mislib
 | /modlib
 | /openlib (Optional – Required for LANSA Open System Utilities)
 | /pgmlib
/as400I |
 | /client (Optional – LANSA client)
 | /help_ml (Optional – Multilingual Help)
 | /help_nml (Optional – Non-Multilingual Help)
 | /modeller (Optional – LANSA Modeller)
 | /persys (Optional – Personal Demonstration System)
 | /persysx (Optional – Personal Demonstration System (RDMLX))
 | /sysflds (Optional – System Fields)
 | /sysvar (Optional – System Variables)
 | /sysvaru (Optional – System Variables)
 | /template (Optional – Templates)
 | /tmp (Required - Images Part 2)

Ý How to Create a Silent Install


Estimating Execution Requirements

The requirements of the "end user" environment where a Visual LANSA application is executed will depend on the size and complexity of the application and how much data will be stored in the database that it will use.

We recommend that you calculate a minimum supported configuration and prepare a Minimum Supported Configuration Document where you formally define the minimum configuration your solution will viably support, including what servers, client platforms and web browsers your application will need. Consider:

  • Minimum hardware requirements
  • Minimum software requirements
  • Supported screen resolutions
  • Minimum networking capabilities
  • Maximum data volumes.

A formal Minimum Supported Configuration (MSC) Document will:

  • Inform decisions about the overall solution cost
  • Establish the environment required to test the deployment of the solution or any patch/hotfix made to it.
  • Raise management's awareness of the risk of implementing a "sub-MSC" solution.

Note - Any other application running on this "end-user" environment must also be considered when sizing your machine.


Disclaimer

While every effort has been made to ensure that the information in the LANSA documentation is accurate. In no event shall LANSA be liable for any damages arising from its use.

LANSA MAKES NO WARRANTIES, EXPRESSED OR IMPLIED.

Copyright and trademark information

© LANSA. "LANSA" is a trade name and registered trademark of LANSA in the United States of America, Australia, the United Kingdom and other countries. All rights reserved.

The following are some companies which require attribution:

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United States, other countries, or both. Microsoft, Windows, .NET and the Windows logo are trademarks of Microsoft Corporation in the United States, other countries, or both.

Other company, product, and service names may be trademarks or service marks of others.

This material may contain other proprietary notices and copyright information, the terms of which must be observed and followed.