LANSA for the iSeries and API changes introduced in i5 from V5R3 and above

Date:Archived
Product/Release:LANSA for the iSeries V10.0
Abstract:LANSA for the iSeries V10.0 and QSYGETPH in i5 V5R3 and higher
Submitted By:LANSA Technical Support

Description:

Some issues have been discovered when testing LANSA V10.0 on V5R3 and higher that affect LANSA and will have to be addressed via EPC. For example, in V5R3, QSYGETPH requires new arguments. Because they were previously optional arguments, we will have to make a change to LANSA to cater for this change or the LANSA Listener TP jobs will fail with a security error.  Also and LANSA Integrator - Open/Close not working due to the NULL (keywordList) buffer parameter. 

Be aware that, depending on the LANSA features used, upgrading to any version of i5 from V5R3 or higher can cause your LANSA applications to fail. Contact your local LANSA distributor to get the latest updates prior to upgrading your OS/400 operating system.

Update:

V5R3 is now Generally Available (released in June 2004).

We have finalised our V5R3 testing and an EPC is available to cater for the issues that affect LANSA. This EPC is only available for LANSA V10.0. As well as several software changes, there are documentation and configuration changes eg. HTTP Server powered by Apache is the default Web server in V5R3.