MCH3601 QC2POSIX error on V5R1 after applying EPCs to LANSA 11.3 (CU3)

Date:31 January 2007
Product/Release:LANSA for iSeries V11.3
Abstract:QC2POSIX error on V5R1 after applying post CU3 EPCs
Submitted By:LANSA Technical Support

Description:

The following applies to V5R1 only.

Any EPC post EPC771 (EPC771 is also referred to as CU3) should not be applied to a LANSA 11.3 system if this LANSA system is on OS/400 V5R1. This specifically means you cannot apply EPC790 or higher to LANSA 11.3. By applying post CU3 EPCs to a LANSA 11.3 environment, you may generate a connection error when connecting to V5R1 via the LANSA Listener. The error in the iSeries joblog is:

MCH3601 Escape 40 29/01/07 15:26:07 QC2POSIX QSYS *STMT QC2POSIX QSYS *STMT
From module . . . . . . . . : QC2PLOCL
From procedure . . . . . . : _C_load_DB_ctype
Statement . . . . . . . . . : 2355
To module . . . . . . . . . : QC2PLOCL
To procedure . . . . . . . : _C_load_DB_ctype
Statement . . . . . . . . . : 2355
Message . . . . : Pointer not set for location referenced.
Cause . . . . . : A pointer was used, either directly or as a basing
pointer, that has not been set to an address.

 
  • This error is specific to V5R1.
  • V5R1 is no longer supported by IBM.
  • This error does not occur on current IBM supported OS/400 versions.
  • This error can occur when using any or all of the following LANSA features
    - LANSA Host Monitor
    - LANSA Superserver
    - Model B LANSA for the web
    - LANSA Open
    - LANSA Client
    - any other LANSA product or feature that use the LANSA listener

There is no circumvention available from LANSA for this error. LANSA recommends that you restore from your latest backup prior to applying any post CU3 EPCs. You must upgrade to a supported version of OS/400 before applying any post CU3 EPC.

Solution:

There is no circumvention available from LANSA for this error. If you generate this error after applying a post CU3 EPC, LANSA recommends that you restore from your last backup prior to applying the post CU3 EPCs. You must upgrade to a supported version of OS/400 before applying any post CU3 EPC.