Crystal Reports XI cannot open DBF file created in LANSA Client V11.3
| Date: | 8 February 2007 |
|---|---|
| Product/Release: | LANSA Client V11.3 |
| Abstract: | A DBF file created with LANSA Client V 11.3 will not open when creating a report with Crystal Reports XI |
| Submitted By: | LANSA Technical Support |
Description:
LANSA Client can output to file type dbf.
A DBF file created with LANSA Client V11.3 will not open when creating a report with Crystal Reports XI.
The error message generated in Crystal Reports XI is:

Cause:
This error is generated due to a change in the way native database drivers are handled in Crystal Reports XI. DBF support is not installed by default by Crystal Reports XI. To review a discussion of this change, review article c2018235 on the SAP/Crystal Reports web site.
Solution:
The resolution is to open the database file as an xBase data source. However, xBase is not on the default list of database drivers and must be added on demand. In order to add it perform the following steps:
- In Crystal Reports XI, under New Reports/Standard Reports
Wizard, go to Create new connection/More data sources/xBase. You
will then be prompted to insert the Crystal Reports
installation CD.
- Insert the LANSA Client V11.3 CD2.
- After the setup has completed you will be able to open DBF files as normal.
xBase will now appear under Create new connection instead of being in More data sources.
In addition to the above, you can also use Create new connection/Database files to open DBF files (as well as Create new connection/xBase).