Unable to restore V11 SP5 objects to QTEMP on V5R4 or earlier versions

Date:22 September 2008
Product/Release:LANSA for iSeries V11 SP5
Abstract:Full support of IBM i 6.1 in V11 SP5 may require users of V5R4 or earlier versions to apply necessary IBM PTFs in order to restore SP5 objects
Submitted By:LANSA Technical Support
Updated:18 May 2012

Description:

From V11 SP5, IBM i 6.1 is fully supported. LANSA SP5 objects (EPCs, patches) are built on IBM i 6.1 so they can then be restored by customers on IBM i 6.1. PTFs are required for any objects saved on IBM i 6.1 before they can be restored on previous IBM i versions.

Sample error message for objects built on IBM i 6.1 but restore attempt on V5R4:

Message ID . . . . . . : CPF3888
Date sent . . . . . . : 09/11/08 Time sent . . . . . . : 00:49:19

Message . . . . : PGM DC@P8170 not restored to QTEMP.

Cause . . . . . :
    If the object is a database file, an unexpected failure occurred during
    the restore of a file member. The member was not restored.
    If the object is not a database file, then the conversion needed to make
    the object compatible with the current system is not possible, so the object
    was not restored.
    If the object is a program, module, service program, or SQL package, then
    either the object may not have the required creation data needed to perform
    the conversion, or there was an unexpected error. Conversion of these object
    types during restore is controlled by the Force Conversion on Restore
    (QFRCCVNRST) system value and the Force Object Conversion (FRCOBJCVN)

Solution:
Ensure these PTFs are applied: (check IBM websites for other OS versions).

Note regarding PTFs: Applying PTFs is an IBM i administration task and assumes a level of knowledge and understanding of the Operating System. The MFXXXXX PTFs listed below are microcode PTFs and need to be applied at the correct Licensed Internal Code (LIC) level. Use the DSPSFWRSC (and F11) to establish the correct level of 57xx999 (LIC) prior to applying the PTF.

V5R3M0
This is no longer an IBM supported Version. You are required to upgrade your OS version before applying V11 SP5.

V5R4M5
MF42655, delayed PTF to be applied at IPL

V5R4M0
MF40520, delayed PTF to be applied at IPL
SI27294, apply immediate or delayed

V5R2 all versions
This is no longer an IBM supported Version. You are required to upgrade your OS version before applying V11 SP5.