Altova MapForce will NOT work with certain versions of IBM System i Access for Windows service level

Date:9th July 2009
Product/Release:LANSA Composer
Abstract:Altova MapForce will NOT work with certain versions IBM System i Access for Windows service level
Submitted By:LANSA Technical Support

Description:

The following may be applicable to you if you are having issues establishing ODBC connections to your iSeries Database using ALTOVA Mapforce.

Note: The impact of this is limited to design-time. Existing transformation maps will continue to operate as before (The client PC is not involved and ODBC is NOT used at run-time).

On MapForce version 2009 SP1, the symptom is that, having established the ODBC connection, the Insert Database Objects displays [NULL] instead of the schema/library name (as shown below). On earlier versions of MapForce (eg: 2008R2SP2 as shipped with LANSA Composer version 2.0), the available library/schema names are simply not shown at all.

Insert Database Objects displays [NULL]

Cause:

Altova MapForce (any version) will be unable to successfully establish ODBC connections to your iSeries database if you install these recent service packs for IBM System i Access For Windows on the client computer on which you are using LANSA Composer and MapForce:

  • Service level SI32504 for IBM System i Access for Windows V6R1M0
  • Service level SI32972 for IBM System i Access for Windows V5R4M0

We believe this is a problem with the iSeries Access ODBC driver installed with these service packs. For SI32504 at V6R1M0, the driver version is 12.00.02.00. Note that other ODBC applications may function correctly, but this is simply because they use ODBC in a different way to Altova MapForce.

Note: If you are having problems establishing the ODBC connection to your System i database from Altova MapForce but it does not match this description, then please also refer to the following Technical Note : Latest DATABASE GROUP PTFs for i5/OS V6R1 may cause temporary/transient problem with Altova MapForce

Solution:

The issue with the IBM System i Access For Windows has been corrected.
IBM have just released service level SI34289 for IBM System i Access for Windows V6R1M0. This service level updates the ODBC driver to version 12.00.05.00, which corrects the problem and works correctly with Altova MapForce.

We understand that IBM will shortly issue an update for V5R4M0 which we expect will correct the problem at that level.

What you should do:

Do NOT install the following updates to IBM System i Access for Windows:

  • Service level SI32504 for IBM System i Access for Windows V6R1M0
  • Service level SI32972 for IBM System i Access for Windows V5R4M0

If you have already installed one of the above:

  • If you are using IBM System i Access for Windows V6R1M0, update to the later service level SI34289
  • If you are using IBM System i Access for Windows V5R4M0, either:
    1. wait for the next IBM update we expect to be released shortly, OR
    2. uninstall IBM System i Access for Windows and re-install at an earlier service level