Using LANSA Integrator EPC722 and Java 1.4 requires PASE to be installed on the iSeries

Date:Archived
Product/Release:LANSA Integrator V10 (EPC722)
Abstract:LANSA Integrators STRJSM can fail if PASE not installed when using Java 1.4
Submitted By:LANSA Technical Support

Description:

EPC722 ships the latest fixes and enhancements for LANSA Integrator V10. EPC722 includes a particular Java system property in the RUNJSM CL program that causes a Java / PASE (Portable App Solutions Environment) environment to start.

Using Java 1.4, for JSM to start requires PASE to be installed. If it is not installed, the STRJSM will crash. The error isn't immediately clear. Check the JSM job JSMJOB and in the job outq a report is generated with the following lines:

Unable to run OS/400 PASE startup program /usr/lib/start32
Unable to create Java Virtual Machine
Java program completed with exit code 1.

Using Java 1.3, this problem will not occur.

Conclusion:

Using LANSA Integrator EPC722 and Java 1.4 requires PASE to be installed on the iSeries.