How to confirm JAVA Version on iSeries

Date:20 January 2005
Product/Release:LANSA Integrator
Abstract:Confirm JAVA version on iSeries
Submitted By:LANSA Technical Support
Last Review:November 2010

There may be instances where the latest installed version of Java has actually not been activated on the iSeries and which can cause problems trying to run LANSA Integrator.

To check to see which version the iSeries has currently activated run the command:

JAVA *VERSION

which will return the current Java version being used ie:

Version JVM V5R2M0 JDK 1.3.1

Currently, the lowest version that should be used (and installed) is JDK 1.4.

There are three methods to allow the correct Java version.

  1. When calling STRJSM, specify theJava version.

    Start Java Service Manager (STRJSM)

    Type choices, press Enter.

    Instance . . . . . . . . . . . . *DEFAULT
    JVM Version  . . . . . . . . . . *DEFAULT  *DEFAULT, *JVM12, *JVM13, *JVM14, *JVM15 
    Option . . . . . . . . . . . . . *NONE     *NONE, *VERBOSE, *VERBOSEGC..
    Garbage collect initial size . . 40000     256-139264000 kilobytes
    Time zone  . . . . . . . . . . . *DEFAULT
     
  2. For LANSA Integrator, edit the SystemDefault.properties file in the system folder to point to the correct version of JAVA.

    /jsm/instance/system/SystemDefault.properties

    Edit the file with the following line:

    java.version=1.3' or whichever version you require.

    e.g:

    #!<studio-project id="20040000-000000" name="test">
    #
    java.version=1.4
    #
    #!</studio-project>


    Note: You will need to restart JSM after making this change.

  3. Or you can change the overall JAVA version on the iSeries:
    1. Use command WRKLNK
    2. Use option 2 to the directory /QIBM/UserData/Java400
    3. Edit the file ‘/QIBM/UserData/Java400/SystemDefault.properties' with the following line:

      'java.version=1.3' or whichever version you require.