Troubleshooting common SQL Server errors and return codes

Date:11 October 2018
Product/Release:Visual LANSA - All supported versions
Abstract:Common SQL Server errors and return codes you may encounter when installing or using Visual LANSA and steps to resolve them.
Submitted By:LANSA Technical Support

Description:

This page lists some common SQL Server errors that you might encounter when installing or using Visual LANSA and steps to resolve the issues. This page will be updated with new errors and return codes as they come to our attention.

Error: Unable to install Microsoft Visual C++ 2015 Redistributable because Microsoft Visual C++ 2017 is already installed.

Diagnosis

Open Summary.txt. This file is located in %ProgramFiles%\Microsoft SQL Server\140\Setup Bootstrap\Log. The following indicates the key values to look for.

"Overall Summary" section (usually located towards the top of the file)
Final Result: Failed
Exit code (Decimal): A non-zero value

"Detailed results" section (usually located towards the bottom of the file)
Status: Failed
Reason for failure: An error occurred for a dependency of the feature causing the setup process for the feature to fail.
Component name: Microsoft Visual C++ 2015 Redistributable
Component error code: 1638
Error description: VS Shell installation has failed with exit code 1638.

Solution

  1. Uninstall the Microsoft Visual C++ 2017 Redistributable (x86) and (x64)
  2. Install SQL Server
  3. Reinstall the Microsoft Visual C++ 2017 Redistributable (x86) and (x64)
    The Redistributable may be found on Microsoft’s website. The location at time of writing was https://visualstudio.microsoft.com/downloads/

Error: System administrator ("sa") password does not meet strong password requirements.

Diagnosis

Open Summary.txt. This file is located in %ProgramFiles%\Microsoft SQL Server\140\Setup Bootstrap\Log. The following indicates the key values to look for.

"Overall Summary" section (usually located towards the top of the file)
Final Result: Failed
Exit code (Decimal): A non-zero value
Exit message: The specified sa password does not meet strong password requirements. For more information about strong password requirements, see "Database Engine Configuration - Account Provisioning" in Setup Help or in %SQL_PRODUCT_SHORT_NAME% Books Online.

Solution

Rerun the Visual LANSA install and specify a stronger password. The "sa" password may be specified by clicking the “Optional Parameters” button next to the database instance on the Database panel. Check with your network administrator to establish if there is a strong password policy enforced at the network (domain) level.